Router Commands, IPX, Cisco, Frame Relay, IP, WAN, PPP.IGRP, RIP and other router commands

Router Commands are used to perform different type of task like configuration. There are lots of router commands used to perform a variety of functions on the basic and advance level. Before knowing about Router command we have to know what is Routing and its basic task.

Routing: – Routing enable the data or packets to move across the inter network. The basic tasks of Router are two in which one is define the path for data and then forward the data on the basis of define path. We can also say that Router make enable the communication between two logical or physical networks.

Keyboard shortcut keys for Router

  • CTRL-N – This short key is used to show next command of Router
  • CTRL-P – This short key is used to show previous executed command
  • SHIFT-CTRL-6 This short key is used for break purpose.

Configuring the Router command

For the configuration of a router there are different types of command used to perform different type of task as under.

  • sh running-config – This command is used to display details of the executing
  • configuration file as (RAM)
  • sh startup-config – Used to show the stored configuration from NVRAM
  • setup – If the Router is booting very first time then it is used to execute automatic setup.
    config t –This command is used for terminal purposes.
    config mem – It is used to carry out configuration commands which are stored in NVRAM; It is also used to copies startup-configuration to running-configuration.
  • config net -It is used to recover configuration information from a TFTP server
  • copy running-config startup-config – This command is used to copies configuration which is saved in running config (RAM) to NVRAM or “write memory” for IOS under ver.11
  • copy startup-config running-config – This command is used to copies from non-volatile (NVRAM) to current running configuration (RAM)
  • boot system flash <File name > – This command is used to tells the router which IOS file exist in flash to boot from
  • boot system tftp – This command is used to tell the router about the IOS file on the tftp server boot from.
  • boot system rom – It is used to makes possible router boot from the ROM
  • copy flash tftp – This command is used to copies files form flash to tftp server.
  • copy tftp flash – It is used to restores all flash data from tftp server.
  • copy run tftp – It is used to copy the running configuration to tftp server
  • copy tftp run – It is used to restores the running-configuration from tftp server

General Router Commands

General Router Commands are most commonly used command for router to perform different type of task depends on the network requirement.

  • reload – This command is used to restart the router.
    sh ver –This command is used to display the uptime of router and to know how the router stated .It is also used to know that where system was loaded and the interface of post founded and register configuration
  • sh clock –This command is used to display the time and date on router
    sh history – If you want to know the history of your last applied commands then you can use this command.
    sh debug – This command is used to display enabled debugging information.
  • no debug all – It is used to turns off all debugging.
    sh users – This command is used to display the information about the user connected to router
    sh protocols – It is used to show configured protocols

NOTE: – If you want to configure a host name on router then issue following command

  • Command: – banner motd # your message # – Set/change banner hostname <give router name>
  • Clear counters –This command is used to clear the screen interface.

Privileged Mode commands of a router

These commands are used to facilitate the user to get enter in the privileged mode of a router.

  • enable –This command is used for entrance in privileged mode
  • disable – It is used to go back towards user mode
  • enable password <give password here> -This command is used to set a password for privileged mode
  • enable secret <give password here> – This command is used to sets a password for encrypted privileged mode

Router Commands for Processes & Statistics

These commands are used to display the statistics and processes of the Router.

  • sh processes – this command is used to display the current running process on router.
  • sh process cpu – This command is used to show the statistics of the cpu.
  • sh mem – It is used to display the information about the memory statistics
  • sh flash – It is used to display information about flash memory and also show the size of files exist in flash and amount of free usable memory.
  • sh buffers – It is used to display the statistics about router buffer pools. It also show the size which may be small, big, middle, very large or very big
  • sh stacks – This command is used to display the reason of reboot and also observe the stack used for processes and interrupts schedule.

IP Commands

IP Commands are used to configure any IP on an interface.

  • int serial 0
    ip address 157.89.1.3 255.255.0.0
  • int eth 0
    ip address 2008.1.1.4 255.255.255.0
  • Other IP Commands:
  • sh ip route – It is used to keep a view on ip routing table
  • ip route <remote_network> <mask> <default_gateway> [administrative_distance] – This command is used to configure a static IP route
  • ip route 0.0.0.0 0.0.0.0 <put gateway of the last resort here> – It is used to sets default gateway
  • ip classless – It is used with static routing and offering packets intended for unknown subnets to use the best possible route
  • sh arp – It is used to view arp cache. It is also used to shows MAC address of linked routers.
  • ip address 2.2.2.2 255.255.255.0 secondary – It is used to configure another IP address on an interface
    sh ip protocol .

Cisco Discovery Protocol Commands

These commands are uses layer 2 multicasts over a SNAP-capable link to send data

  • sh cdp neighbor – It is used to display connected neighbors which are directly connected
  • sh cdp int – This command is used to display about which interfaces are running CDP
  • sh cdp int eth 0/0 – It is used to show information about CDP for specific interface
  • sh cdp entry <cdp neighbor here> – It is used to display the CDP neighbor detail
  • cdp timer 120 – It is used to make changes how often CDP info is sent (default cdp timer is 60)
  • cp holdtime 240 – It is used to tell how long to wait before removing a CDP neighbor (default CDP holdtime is 180)
  • sh cdp run – If a user turn on a CDP then it comes.
  • no cdp run – It is used to turns off CDP for entire router
  • no cdp enable –It is used to turns off CDP on exact interface.

IPX Commands

These commands are used to make possible to run any IPX on router.

  • ipx routing
    Used to configure IPX + IPX-RIP on an int:
  • int ser 0
    ipx network 4A
  • sh ipx route – It is used to display IPX routing table
  • sh ipx int e0 – It is used to shows ipx address on int
  • sh ipx servers – It is used to display SAP table
  • sh ipx traffic – through this command you can view traffic statistics
  • debug ipx routing activity – It is used to debugs IPS RIP packets
  • debug ipx sap – It is used to debugs SAP packets

Routing Protocols Commands

The Routing Protocols Commands are three as RIP, IGPR and OSPF

  • Configure RIP:
    router rip
    network 157.89.0.0
    network 208.1.1.0

Other RIP Commands:

  • debug ip rip – This command is used to view information about RIP debugging
    Configure IGRP:
    router IGRP 200
  • network 157.89.0.0
    network 208.1.1.0

Other IGRP Commands:-

  • debug ip igrp events –This command is used to display information about IGRP debugging.
  • debug ip igrp transactions – It is used to view IGRP debugging info

Access Lists

Access list commands of a router are under

  • sh ip int ser 0 –This command is used to show which IP access lists are applies to which interface.
  • sh ipx int ser 0 – It is used to view which IPX access lists are applies to which interface.
  • sh appletalk int ser 0 – It is used to show about AppleTalk access lists are applies to which interface.

View access lists

  • sh access-lists
  • sh ip access-lists
  • sh ipx access-lists
  • sh appletalk access-lists
  • Apply standard IP access list to int eth 0:
  • access-list 1 deny 200.1.1.0 0.0.0.255
  • access-list 1 permit any

int eth 0

ip access-group 1 in
Apply Extended IP access list to int eth 0:
access-list 100 deny tcp host 1.1.1.1 host 2.2.2.2 eq 23
access-list 100 deny tcp 3.3.3.0 0.0.0.255 any eq 80

int eth 0
ip access-group 100 out
Apply Standard IPX access list to int eth 0:
access-list 800 deny 7a 8000
access-list 800 permit -1

int eth 0
ipx access-group 800 out
Apply Standard IPX access list to int eth 0:
access-list 900 deny sap any 3378 -1
access-list 900 permit sap any all -1

int eth 0
ipx access-group 900 out

WAN Configurations Commands

Router is used for connectivity in a network because networking is the main functionality of router. There are some commands for various method of connectivity.

PPP Configuration

For WAN connectivity the point to point protocol is a well known method of a network.here are some commands as under

  • encapsulation pppppp authentication <chap or pap here>
  • ppp chap hostname < router name>
  • ppp pap sent-username <user name >
  • sh int ser 0 – It is used to show encapsulation on the interface

Frame-Relay Configuration

Frame-Relay Configuration is the best method for connectivity of WAN. The basic commands of Frame-Relay are under.

  • encapsulation frame-relay ietf – When the setting of frame-relay network between a Ciscorouter and a non-Cisco router are going on then use IETF.
  • frame-relay lmi-type ansi – LMI types are Cisco, ANSI, Q933A; Cisco is the default; LMI type is auto-sensed in IOS v11.2 and up
  • frame-relay map ip 3.3.3.3 100 broadcast – if opposite ARP won’t work, map Other IP to Your DLCI # (local)
  • keep alive 10 – use to set keep alive
  • sh int ser 0 – This command is used to show DLCI, LMI, and encapsulation information.
  • sh frame-relay pvc – It is used to shows the configured DLCI’s, also shows PVC traffic stats
  • sh frame-relay map – It is used to shows route mapssh frame-relay lmi – shows LMI information.

Miscellaneous Router Commands

There are some other command used for various functionality

  • sh controller t1 – It is a useful command to shows status of T1 lines
  • sh controller serial 1 – This command is use to conclude if DCE or DTE device
  • (config-if)#clock rate 6400 –It is used to set clock on DCE (bits per second)
  • (config-if)#bandwidth 64 – This command is sued to set bandwidth (kilobits)

Leave a Reply

Your email address will not be published. Required fields are marked *